Forums / Support / Delete4Sure and Windows 8

Delete4Sure and Windows 8

Is Delete4Sure compatible with Windows 8? I'm migrating from Xp to a laptop and

BinaryBoy's reply to ahartley #17234 @

Yes, it will work as usual in desktop windows on Windows 8. I haven't tested it on 8.1 yet but it should work there too.

ahartley's reply to BinaryBoy #17253 @

I installed Delete4Sure but no context menu appears when I right-click a file to delete. The regular delete is there but nothing for D4S. I tried uninstalling, a reboot, and reinstall, but no good. There is a directory for D4S, so it's installing it. Any ideas? I'm running Win8. I have not yet installed Win8.1. I'm running it on a Toshiba S55-A5295 64-bit laptop.

BinaryBoy's reply to ahartley #17254 @

There are certain places it won't appear, like in system folders and the Desktop. Try going to the Documents folder and right-clicking something. Does it show up there? I previously had it running on Windows 8 and now am running it on Windows 8.1 directly from the web site to be sure it's the same as everyone elses.

ahartley's reply to BinaryBoy #17255 @

I tried the Documents folder and a folder I had created with images in it. No good. D4S doesn't appear in the menu.

BinaryBoy's reply to ahartley #17256 @

Try this.

Tap the Windows key to get to the Start screen.

Type cmd.exe but don't press Enter.

Right-click the cmd.exe icon and click Run as Administrator

At the command prompt type this, including the quotes:

regsvr32.exe "c:\program files\delete4sure\delete4sure.dll"

BinaryBoy's reply to BinaryBoy #17257 @

P.S. Have you ever allowed a trial of Delete4Sure to expire on this computer?

BinaryBoy's reply to BinaryBoy #17261 @

It will act as a trial until a reg code is entered. The problem sounds like you're running an older version that doesn't have 64-bit support. Where did you download it from? Try this installer instead:

ahartley's reply to BinaryBoy #17262 @

That nailed it! I uninstalled my version and installed the new, and it came right up. New file was twice the filesize of mine. Thank you!

BinaryBoy's reply to ahartley #17263 @